본문 바로가기

개발/unix

solaris 정리 4 - [ Device ]

Device 설정 정보 보기
- Device Naming Conventions
Logical device name : /etc/dev/
Physical device name : /devices
Instance name : /etc/path_to_inst

- # cat /etc/path_to_inst  (인식하는 정보만 보여줌)
각 device의 instance name, number와 physical name display
  sd : disk
  fd : floppy disk
  se : serial ports A and B
  st : tape devices
  power : power management bus
  su0 : keyboard   su1 : mouse
  audiocs : crystal semiconductor
  ecpp : extended capability parallel port
  hme : fast ethernet

- # dmesg
각 device들의 physical name, OS revision number, ethernet address, physical memory
size 등 확인.
= # more /var/adm/messages

- # prtconf  (인식하지 않는 정보도 보여줌)
  /etc/prtconf -> ../usr/sbin/prtconf
  memory, peripheral configuration 등의 시스템 구성 정보 출력.
  -F : console frame buffer의 pathname
  -P : PROM mode의 정보
  -p : pseudo device 정보
  -v : verbose mode
  # prtconf | grep -v not ('not' 포함하는 라인을 생략하고 정보 출력)
  # prtconf | grep Memory (memory 확인)

- # psrinfo -v (cpu clock 확인)
- # isainfo -kv (32 or 64bit 확인)

- # sysdef
  prtconf 이외의 추가정보 보여줌.
  hostid, pseudo devices, loadavle modules, H/W device, select kernel parameter값,     system device
  # sysdef | grep -v not | more

- # format
  disk 선택
  format -> partition -> print
  partition 수정
  label -> buffer -> VTOC(파일시스템의 0번째 섹터,512byte,디스크정보 포함)
  name test01
  save -> /etc/format.dat에 저장
  사용가능한 disk의 physical device name과 logical device name 출력.
  ^D를 누르면 메뉴에서 빠져 나옴.

- # prtvtoc /dev/rdsk/c0t0d0s2  (VTOC 내용 확인)

- Relabeling a Disk (disk의 VTOC 정보를 그대로 사용하고 싶을때)
# prtvtoc /dev/rdsk/c0t0d0s2 > /vtoc (VTOC 백업)
# ftp 192.168.0.151
ftp> put vtoc
# dd if=/dev/zero of=/dev/rdsk/c0t0d0s2 bs=512 count=1
(VTOC=512byte  VTOC가 512byte이므로 1번만 넘김.)
ok> boot cdrom -s
# TERM=sun  (vi editor enable)
# export TERM
# ifconfig -a
# ifconfig hme0 192.168.0.150 up
# cd /tmp/root
# ftp 192.168.0.151
ftp> get vtoc
# fmthard -s ./vtoc /dev/rdsk/c0t0d0s2  (VTOC 복구)

- 하드디스크 백업
# dd if=/dev/rdsk/c0t0d0s2 of=/dev/rdsk/c0t1d0s2 bs=1024
                                                  1024byte 단위로 전송




Device 재구성
- /reconfigure 파일 이용 (/dev, /devices, /etc/path_to_inst에 동시 등록)
# touch /reconfigure
# init 5
추가 disk 연결
power on

- ok mode에서 인식 (/dev, /devices, /etc/path_to_inst에 동시 등록)
ok> boot -r

- reboot하면서 인식 (/dev, /devices, /etc/path_to_inst에 동시 등록)
# reboot -- -r

- prompt상에서 바로 인식 (/dev, /devices, /etc/path_to_inst에 동시 등록)
# devfsadm  (Solaris8 이상에서 사용)
시스템의 모든 driver를 로드하기 위해 시도하고 가능한 모든 device instance 추가
# devfsadm -c disk
# devfsadm -c disk -c tape -c audio (여러개의 device class 명시)
# devfsadm -i dad (dad driver에 의해 지원되는 disk들만 구성)
# devfsadm -i sd (sd driver에 의해 지원되는 disk들만 구성)
# devfsadm -i st (st driver에 의해 지원되는 disk들만 구성)

# drvconfig (/devices, /etc/path_to_inst에 등록, Solaris7에서 사용)
# devlinks [disks or nets or ports]  (/dev에 등록)